Admin panel not working after fresh install

Hey,

I had my pimcore instance on 5.x, but wanted to go for 6.x by starting from scratch. Dropped database, rm -rf’d project directory, cleared redis cache and proceeded to upgrade php-fpm from 7.1 to 7.2. Changed nginx config to new one for 6.x as well. After it was done, I started with
https://pimcore.com/docs/6.x/Development_Documentation/Getting_Started/Installation.html
Unfortunately, after I’m done and site is up (homepage working properly), the admin panel (/admin) doesn’t load and is stuck in perma loading screen, despite returning 200:


There are no errors in nginx, php logs. There are only DEBUG and INFO lines in pimcore logs.

Have anyone faced such issue?

This usually happens when your web user doesn’t have permissions to view the admin assets. Try adding the option to read as the web user to your vendor folder recursively.

I have everything on a single user for testing purpouses (nginx, php, pimcore app), eg:

Summary

(XYZ is the same user)
ps aux:

XYZ@pimcore:/var/www/pimcore/XYZ$ ps aux | grep -E "(php|nginx)"
root     14974  0.0  0.4 492840 33288 ?        Ss   Oct30   0:03 php-fpm: master process (/etc/php/7.2/fpm/php-fpm.conf)
XYZ+ 14975  0.0  1.3 510340 107920 ?       S    Oct30   0:06 php-fpm: pool www
XYZ+ 14976  0.0  1.2 512304 102252 ?       S    Oct30   0:04 php-fpm: pool www
XYZ+ 15032  0.0  1.2 512324 100668 ?       S    Oct30   0:04 php-fpm: pool www
XYZ+ 18722  0.0  0.0  12776   876 pts/2    S+   14:42   0:00 grep -E (php|nginx)
root     24126  0.0  0.0 159996  1788 ?        Ss   Oct30   0:00 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
XYZ+ 24127  0.0  0.0 160744  5248 ?        S    Oct30   0:00 nginx: worker process
XYZ+ 24128  0.0  0.0 160372  3368 ?        S    Oct30   0:04 nginx: worker process
XYZ+ 24129  0.0  0.0 160372  3368 ?        S    Oct30   0:03 nginx: worker process
XYZ+ 24130  0.0  0.0 160372  3368 ?        S    Oct30   0:04 nginx: worker process

files:

XYZ@pimcore:/var/www/pimcore/XYZ$ ls -l
total 456
drwxr-xr-x  4 XYZ XYZ   4096 Oct 30 13:21 app
drwxr-xr-x  2 XYZ XYZ   4096 Sep 24 14:50 bin
-rw-r--r--  1 XYZ XYZ   1936 Sep 24 14:50 composer.json
and so on...

so that shouldn’t be the case I guess?

Yeah, but your web-user (usually www-data on Ubuntu) needs to have access to your assets to be able to display them.

I usually set my user to www-data group, then make everything readable according to this: https://pimcore.com/docs/6.x/Development_Documentation/Installation_and_Upgrade/System_Setup_and_Hosting/File_Permissions.html

And after that run chmod g+w on those folders so that both my processes and web user can write in those folders.

Yeah, I totally get that, BUT, as I’ve mentioned above:

(XYZ is the same user)

XYZ+ 14975  0.0  1.3 510340 107920 ?       S    Oct30   0:06 php-fpm: pool www
XYZ+ 24128  0.0  0.0 160372  3368 ?        S    Oct30   0:04 nginx: worker process
drwxr-xr-x  4 XYZ XYZ   4096 Oct 30 13:21 web

which means that both web server and php run as the same user that created pimcore project and the same user that has full permissions to it. It’s same as you would su - www-data that runs nginx and php, and would create pimcore project as that user.

Any ideas anyone? Tried reinstalling once again, but got the same issue.

@Teqashi take a look on a browser’s console and network tab - that’s where you should find the answer.

@Teqashi
can you please try following commands
./bin/console pimcore:deployment:classes-rebuild -d -c
./bin/console assets:install web
./bin/console cache:clear

@rushit-credencys
Unfortunately, that did not help.

@jplaskonka


Sadly I’m not a dev so I don’t really know what that means :frowning: