Can't install pimcore after using clone from git

May i know the steps to clone a pimcore project. I did clone it and use composer update but it didn’t run well than I created db used pimcore-install again had error than I generated the key and added it into config.yml than run again pimcore-install but again it shows this error:
`

You have requested a non-existent parameter “app_encryption_secret”.

`

//composer-update error

An error occurred when executing the “‘cache:clear --no-warmup’” command:
Fatal error: Uncaught Symfony\Component\DependencyInjection\Exception\Param
eterNotFoundException: You have requested a non-existent parameter “app_enc
ryption_secret”. in /var/www/Pimcore/ecommerce-demo-v6/vendor/symfony/symfo
ny/src/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php:
100
Stack trace:
#0 /var/www/Pimcore/ecommerce-demo-v6/vendor/symfony/symfony/src/Symfony/Co
mponent/DependencyInjection/ParameterBag/EnvPlaceholderParameterBag.php(67)
: Symfony\Component\DependencyInjection\ParameterBag\ParameterBag->get(‘app
encryption …’)
#1 /var/www/Pimcore/ecommerce-demo-v6/vendor/symfony/symfony/src/Symfony/Co
mponent/DependencyInjection/ParameterBag/ParameterBag.php(216): Symfony\Com
ponent\DependencyInjection\ParameterBag\EnvPlaceholderParameterBag->get(‘ap
p_encryption_…’)
#2 /var/www/Pimcore/ecommerce-demo-v6/vendor/symfony/symfony/src/Symfony/Co
mponent/DependencyInjection/ParameterBag/ParameterBag.php(187): Symfony\Com
ponent\DependencyInjection\ParameterBag\ParameterBag->resolveString(’%app_e
ncryptio in /var/www/Pimcore/ecommerce-demo-v6/vendor/symfony/symfony/src/S
ymfony/Component/DependencyInjection/ParameterBag/ParameterBag.php on line
100

Your parameters.yml file needs additional parameters, by the looks of it. I think you should have an example parameters file in your installation so just copy it and rename to parameters.yml.

There is actually a bundle outside of Pimcore which takes care of that for you and it’s been a part of Symfony for a while now. You then just need to have a parameters.yml.dist file and composer will set it up for you.

I asked a question about it here, actually: Using a parameters.yml.dist file

@tbuljevic I have the parameters.yml and there is the key generated I also added the parameters.yml.dist and than tries to run composer update, again the same error and if i run pimcore-install again the same:

You have requested a non-existent parameter “app_encryption_secret”.

Than i folloed the pimcore documentation and added the key in config and again the same error.

pimcore:
encryption:
secret:
def00000c4610c0a67d16cb6411ac2a91aadde03512a0fb16d5077f9cf57627e36355c2d39c5332dfd7fd7896e821cbf92a272d55143af00c602b795f976dc42f6d96917

Your parameters.yml file should look like this:

parameters:
     app_encryption_secret: "<your_application_secret_key_change_it"

And that’s it. Try that, and see if it works.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)