Can't Install Pimcore localhost:2000 Docker Dpfaffenbauer - Requires PHP ^7.4 version

Hey All,

I’m running Pimcore on docker based on this reference :

It’s working after docker-compose

image

But somehow it failed after COMPOSER_MEMORY_LIMIT=-1 composer create-project pimcore/demo tmp

it is said :

ocramius/package-version 1.5.1 requires php ^7.3.0 -> your php version (7.2.19) does not satisfy that requirement

ocramius/proxy-manager 2.5.0 requires php ^7.4.0 -> your php version (7.2.19) does not satisfy that requirement

anyone can help with this?
thanks before :pray:

Image for 7.4 is in the making: https://github.com/dpfaffenbauer/pimcore-docker/pull/24

Reason why it requires PHP7.4 for now is: https://github.com/pimcore/skeleton/issues/15

1 Like

wow ok thanks dominik :pray:

I heard some issue that php 7.4 is still unstable and change to php 7.3.5 instead.

Remove the composer.lock file, make sure you have php 7.3 and all neccessary extensions. Then do composer update.

This should do the trick for now.