Changes only appear after manually removing the cache

Hi,

I have a view with a link pointing to a controller using the annotation component.

View :

{% for subCategory in subCategories %}
           <a href="{{ path('shop-category-listing', {'_locale': locale, 'id': subCategory.id, }) }}" class="list-group-item">
                {{ subCategory.name }}
           </a>
{% endfor %}

Controller :


/**
 * @Route("/shop/{_locale}/{id}", name="shop-category-listing")
 */
 public function categorieshAction()
 {
     $this->render('Shop/categories.html.twig', [
           'editmode' => $this->editmode
     ]);
 }

categories.html.twig :

<h1> Lorem</h1>

Whenever I modify the content of this view, I have to manually delete the cache for the changes to appear (or restart docker, which is weird).
When I delete the cache from the back office it does not work.

I have debug mode enabled, in dev mode and I did not change the cache config.

Removing :cached from my docker-compose.yml works but loading pages takes for ever.

It still doesn’t work when i add ?nocache=true to the url, or when i disable the cache in the controller (\Pimcore\Cache::disable();