CMYK to RGB Displaying as Negative


#1

Hi All,

I’m new to Pimcore and trying to get things setup. We heavily use CMYK at my company and it seems that all the CMYK images that are uploaded are displaying as negatives. I’ve uploaded the icc profiles for both RGB and CMYK for the conversion in Pimcore but they are still displaying incorrectly.

The issue is happening for both tif and jpg files that are being uploaded. If I manually convert the color profile in photoshop there is no issues with the upload. If I manually convert the file in imagemagick using "convert “image.tif” -colorspace sRGB “filename.jpg” it displays correctly. This isn’t a viable “fix” though since I have over 4Tb of images I need to move into the system.

I know I’m missing something small but I have no idea what it is. Any help would be much appreciated.

System Info:
Centos 7
PHP 7.2.6
Imagemagick 7.0.7-36

Thanks,

Phil


#2

Hi,
i have the same problem. Any solution ?


#3

had the same issue, solved it like this in my import:

        $i = new \Imagick($path);

        if ($i->getImageColorspace() === \Imagick::COLORSPACE_CMYK) {
            $i->transformImageColorspace(\Imagick::COLORSPACE_RGB);
        }

        return $i->getImageBlob();

#4

Were you using a custom import page or one of the standard pages?

If standard, could you point me to which one? I’d like to modify the drag and drop import from the admin console.

Thanks!


#5

I am using ImportDefinitions to do that.


#6

ok, thanks. I’ll have to look into installing that. I’m currently just running Pim 5 base (with all required/suggested plugins from installer)

I’ll let you know if that works.


#7

Just a quick update, I installed the coreshop/CoreShop and w-vision/ImportDefinitions and now I can’t seem to get Apache to start back up.

Getting the following in the journal:

– Unit httpd.service has begun starting up.
Jun 06 15:04:52 Pimcore systemd[1]: httpd.service: main process exited, code=exited, status=254/n/a
Jun 06 15:04:52 Pimcore kill[4835]: kill: cannot find process “”
Jun 06 15:04:52 Pimcore systemd[1]: httpd.service: control process exited, code=exited status=1
Jun 06 15:06:22 Pimcore systemd[1]: httpd.service stop-sigterm timed out. Killing.
Jun 06 15:06:22 Pimcore systemd[1]: Failed to start The Apache HTTP Server.
– Subject: Unit httpd.service has failed
– Defined-By: systemd
Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

Unit httpd.service has failed.

The result is failed.
Jun 06 15:06:22 Pimcore systemd[1]: Unit httpd.service entered failed state.
Jun 06 15:06:22 Pimcore systemd[1]: httpd.service failed.
Jun 06 15:06:22 Pimcore polkitd[821]: Unregistered Authentication Agent for unix-process:4815:1151852 (sy
lines 3962-3999/3999 (END)


#8

Well, that can’t be related to importdefinitions or CoreShop in any way…


#9

You were correct. Issue was with opcache. I’ve fixed that.

Working through next issue: No route found for “GET /admin/import_definitions/definitions/get-config”

I’ll let you know how it progresses.


#10

First of all thanks for the quick response.
Where do I have to insert the code exactly?


#11

I’ve tried several different things and have been unable to get the conversions to work properly in Pimcore. I was able to get the CMYK files to convert to RGB but the coloring was still wrong.

In the conversion, there appears to be something that isn’t handling the tiff files correctly. I’ve tried the same files on the Pimcore demo site and they work fine. Is there a plugin that needs to be installed in order to allow CMYK files to display properly in tiff and jpeg?

Thanks,

Phil


#12

After giving it some more testing I do have the same coloring issue and no solution for it… I have no idea whats going on. Tried several color profiles but nothing seems to worked.


#13

We were able to resolve this issue.

In order to resolve we had to switch from using Centos 7 to Ubuntu and from Apache to Nginx. Once we setup that way, everything immediately worked.

Thanks,

Phil


#14

how did that resolve the conversion issue?


#15

Running Nginx and Ubuntu resolved the issue. Running the newest version of Pimcore and Imagick, everything worked as expected.

Something in either Apache or Centos must be causing the issue.