Config for Object Data Type "Relation->Objects (Non Owner)" - bugged or not?


#1

Hi,

i tried to create a non owner objects realtion field in an object for an invisible field, but it is not possible.

For example:
News: Has the field “categories” with the config: “Relation”->“Objects” and allowed classes: “Category”.
Now i want to create a new field “news” in the class “Category” which is a “Objects (Non Owner)” to show my users in pimcore which news are in this category.
Now it is possible to do this, but after i changed the “categories” field in my class “News” to “Invisible” i cannot select the field “categories” as “owner field” in the config.
If the “news” field is created before i change the “categories” field to invisible its ok and i see the right data in my objects, but if i try to create the “Non Owner” field after i change the other field to invisible i cannot slecet the invisible field as “Owner field”.

I tried to figger out what is the problem and i found this line:


I think the problem is:

if (!$field->getInvisible()

Same at the newest pimcore version 5.4.2 and at the pimcore version 4.6.4 (demo.pimcore.org)

What do you think? Is that a bug or not?


#2

Hi,
I would say that the call of the method getFieldGridConfig should provide a $force = true as parameter. then all fields should be listed.

BR
Christian