Configure Redis with Pimcore

Hi,

The documentation to configure PimCore to use Redis seems outdated. When I follow the instructions to the new paths nothing is cached in Redis.

What steps do I need to take to cache into Redis?

We use a cache.yml file in /app/config/local/ which looks like:

pimcore:
 #### REDIS CACHE
  cache:
    pools:
      redis:
        enabled: true
        connection:
          server: localhost
          database: xx

Thanks for your reply.

I added a cache.yml file into /app/config/local with the config from the documentation (https://pimcore.com/docs/6.x/Development_Documentation/Development_Tools_and_Details/Cache/index.html). Restarted everything and checked if Redis was doing anything when I reload Pimcore with: redis-cli MONITOR but nothing is showing up there, only OK.

Did you ever get this to work? I’m likewise having an issue getting Pimcore Redis cache to work. Documentation is quite limited on this.

EDIT: It does seem to work after setting up a cache.yml with the IP of the Redis server (we’re using a remote Redis server), port and database. I did a cache:clear, but not sure if it’s necessary, but I now see data with redis-cli monitor.