Deprecation exception while running Pimcore maintenance task

I’m getting a strange deprecation exception while running the Pimcore maintenance script bin/console pimcore:maintenance in Pimcore 5.8.3:

PHP Deprecated: Usage of Manager\Procedural is deprecated since Pimcore 5.7 and will be removed in 6.0. Please use Tagged Services now for Maintenance tasks in /var/www/vendor/pimcore/pimcore/models/Schedule/Manager/Procedural.php on line 70

I couldn’t find anything about this on google or in the official upgrade notes

Anyone knows where this comes from?

Yes, it comes from the maintenance scripts. Ignore it, as its just a deprecation note and this feature will be removed with Pimcore 6.0.

For Sentry Logging: Just disable ErrorExceptions in Logging and you are fine.

1 Like

@dpfaffenbauer Thanks for your response!

I just noticed that I’m also getting the exception message in the backend (system running in prod), where it is sometimes blocking the UI… So when you loading the backend, the message is popping up, then gets overlapped by ExtJS but when you now interact with the backend, it sometimes moves all ExtJS content up and get’s kind of “sticky” at the bottom:

I think this should be fixed before the release of Pimcore 6.0, because it’s a really bad experience for backend users… :slight_smile:

What? That should not appear there… It doesn’t for me…

Have you checked the source code? Should be in the body below the pimcore_body div:

This “sticky” effect (so that it get’s visible) only happens sometimes… I also tried to reproduce it on but for some reason the demo is running the dev-master and not the latest release…

Yeah, I know why it happens.

Guess you have error_reporting E_DEPRECATED enabled and that is why it shows it. I am responsible for the deprecation of the Procedural Manager. The Problem is, Pimcore already started to work on Pimcore 6 thus it is currently not possible to fix that in Pimcore 5.8.*

@brusch That definitely needs fixing, but how? I mean, there is no 5.8 branch to fix that stuff in.

1 Like

Nice, disabling E_DEPRECATED worked :+1:t3:

Thanks for your help :slight_smile: