Does Pimcore installation must use PHP ^7.4?

Hello all, I want to ask about the recent Pimcore installation.

There are 3 problems that requires php 7.3 or even php 7.4.

is it possible to use PHP <7.4 ?

because the console command is still aborted in PHP 7.4. there is an issue that PHP 7.4 is still unstable.


image

Remove the composer.lock file, make sure you have php 7.3 and all neccessary extensions. Then do composer update.

where is the location of composer.lock file? is it after I do the composer create-project? If it’s so, how do I continue after I delete composer.lock file?
image

If I want to install in Apache htdocs, what should I configure?

composer.lock is created by running composer update.