Ecommerce Framework locale wrong in prod mode, bad config?


While in dev mode all the currencies are formatted correctly (CHF 123.45), but when I turn dev off the currencies default to something else (123,45 CHF). Is prod using a different config? It seems like it doesn’t know the locale anymore in prod and defaults to the EUR format.

I have a feeling there might be an issue with my config in general, the parent_order_folder of the order_manager is being ignored and the CMF is not accepting my namingScheme either. It does saves some other settings though, like my paypal credentials or the baseCharge in the cart_mananger.

What is going wrong with my config and why is it different in prod?

It knows the currency formats, but it keeps going back to the default one:


I just tried changing the currency format in the official ecommerce demo with the classic cars stuff:

- [setCurrencyFormat, [‘en’, ‘#.##0,00 ¤¤’]]
- [setCurrencyFormat, [‘de’, ‘¤¤ #.##0,00’]]
#- [setCurrencyFormat, [‘en’, ‘¤¤ #,##0.00’]]
#- [setCurrencyFormat, [‘de’, ‘#,##0.00 ¤¤’]]

It doesn’t work. Is currency formatting just broken? Am I formatting it wrong? Non-€ countries need love too! :slight_smile:

Ok slight mistake on my part, the pattern cant be changed the way i did it. What I want is:

‘¤¤ #,##0.00’

The comma indicates the position of the grouping separator (whatever that means) and the dot shows the position of the decimal separator. And that ¤ symbol shows the position and length of the currency name. Really weird way of showing the format, but whatever. Found that in a post about java by the way.

Problem is still the same. I will propbably just overwrite it directly in the bundle until i discover the intended way of doing it (if there even is one in the first place).