Editables are gone?


#1

Hi there. I have a pimcore installation with some editables.
On the admin panel in the edit tab i can’t see any editables anymore. also none with the “highlight mode”.
Front-end is all good. the content is shown as it was written a time ago. no update done. any proposals what this could be for a problem? thanks!


#2

Check in your console of developer tools if you are getting any javascript errors. Also check under network tab if therer are any failed requests.

Cheers, Igor


#3

Sorry have just seen your post. yes. there are js errors.

Uncaught TypeError: Cannot read property ‘Ext’ of undefined
at klass. (script-proxy?scripts=minified_javascript_core_84eac321285d270b463c489751b60b35.js&_dc=235:38636)
at E.handler (prototype-light.js?_dc=235:261)
at Object.callback (ext-all.js?_dc=235:22)
at E.fireHandler (ext-all.js?_dc=235:22)
at E.onClick (ext-all.js?_dc=235:22)
at E.fire (ext-all.js?_dc=235:22)
at E.fire (ext-all.js?_dc=235:22)
at E.publish (ext-all.js?_dc=235:22)
at E.doDelegatedEvent (ext-all.js?_dc=235:22)
at E.onDelegatedEvent (ext-all.js?_dc=235:22)

and

Uncaught TypeError: Cannot read property ‘Ext’ of null
at klass. (script-proxy?scripts=minified_javascript_core_84eac321285d270b463c489751b60b35.js&_dc=235:38636)
at E.handler (prototype-light.js?_dc=235:261)
at Object.callback (ext-all.js?_dc=235:22)
at E.fireHandler (ext-all.js?_dc=235:22)
at E.onClick (ext-all.js?_dc=235:22)
at E.fire (ext-all.js?_dc=235:22)
at E.fire (ext-all.js?_dc=235:22)
at E.publish (ext-all.js?_dc=235:22)
at E.doDelegatedEvent (ext-all.js?_dc=235:22)
at E.onDelegatedEvent (ext-all.js?_dc=235:22)

what causes this problem?


#4

Did you try to clear your cache with “php bin/console cache:clear”?


#5

yes… done. hans changed nothing. also deleted chache folder on server.
anything else to try?


#6

in the dev console i have the following JS with error:

DOMAIN/HOST/admin/misc/script-proxy?scripts=minified_javascript_core_84eac321285d270b463c489751b60b35.js&_dc=235


#7

After a quick look into the code, it seems to me that something already goes wrong here:

https://github.com/pimcore/pimcore/blob/master/web/pimcore/static6/js/pimcore/document/edit/startup.js#L48 and the variable gets set here:

Not sure, but it seems that the variable is not set properly and therefore editables are broken.


#8

Hmm… good input! For tests i have set up a new live testenviroment. made a fresh installation of PC5 via ssh.
Same result!