Having trouble updating Pimcore 5.8.4 to 6.2.1

I’m finally taking the plunge to update Pimcore to the latest version from 5.8.4. I followed the following guide and updated my composer.json, app.php file. I already had a database.yml file from v5.8.4: https://pimcore.com/docs/6.x/Development_Documentation/Installation_and_Upgrade/Updating_Pimcore/V5_to_V6.html

Here is my composer.json file:

{
  "name": "pimcore/skeleton",
  "type": "project",
  "license": "GPL-3.0-or-later",
  "config": {
    "optimize-autoloader": true,
    "sort-packages": true
  },
  "require": {
    "php": "^7.2",
    "coreshop/core-shop": "^2.1",
    "dachcom-digital/formbuilder": "~3.0.0",
    "ongr/elasticsearch-bundle": "~5.0",
    "pimcore/pimcore": "^6.0.0",
    "wikimedia/composer-merge-plugin": "^1.4",
    "pimcore/customer-management-framework-bundle": "^1"
  },
  "require-dev": {
    "cache/integration-tests": "^0.16.0",
    "codeception/codeception": "~2.4.5"
  },
  "autoload": {
    "psr-4": {
      "": ["src/"],
      "Pimcore\\Model\\DataObject\\": "var/classes/DataObject",
      "Pimcore\\Model\\Object\\": "var/classes/Object",
      "Website\\": "legacy/website/lib"
    },
    "classmap": [
      "app/AppKernel.php"
    ]
  },
  "scripts": {
    "post-create-project-cmd": "Pimcore\\Composer::postCreateProject",
    "post-install-cmd": [
      "Pimcore\\Composer::postInstall",
      "@pimcore-scripts"
    ],
    "post-update-cmd": [
      "Pimcore\\Composer::postUpdate",
      "@pimcore-scripts",
      "Pimcore\\Composer::executeMigrationsUp",
      "@pimcore-scripts"
    ],
    "pimcore-scripts": [
      "Pimcore\\Composer::clearCache",
      "Pimcore\\Composer::installAssets"
    ]
  },
  "extra": {
    "symfony-app-dir": "app",
    "symfony-bin-dir": "bin",
    "symfony-var-dir": "var",
    "symfony-web-dir": "web",
    "symfony-tests-dir": "tests",
    "symfony-assets-install": "relative",
    "merge-plugin": {
      "include": [
        "composer.local.json"
      ],
      "recurse": true,
      "replace": true,
      "merge-dev": true,
      "merge-extra": false,
      "merge-extra-deep": false,
      "merge-scripts": false
    }
  },
  "minimum-stability": "dev",
  "prefer-stable": true
}

It updated a host of packages. I then started getting some warnings about “Too few arguments” for the following files (all on line 33, except the last):

InstallCommand.php
AbstractBundleCommand.php
UninstallCommand.php
UpdateCommand.php
InternalNewsletterDocumentSendCommand.php (line 40)

The final errors after clearing the cache were:
Script Pimcore\Composer::clearCache handling the pimcore-scripts event terminated with an exception

[RuntimeException]
An error occurred when executing the "'cache:clear --no-warmup'" command:

Attempts to access the site or admin result in a 500 error. Looking at the nginx error.log file, the only entries I have are (these errors existed before the update as well):

OCSP_basic_verify() failed (SSL: error:27069065:OCSP routines:OCSP_basic_verify:certificate verify error:Verify error:self signed certificate in certificate chain) while requesting certificate status

Everything was working great with v5.8.4. I have the following server:

Debian 9
Nginx 1.10.3
PHP 7.3.3
MariaDB 10.1.37

Any ideas what to look at next?

EDIT: Got it figured out. I had to tweak a bit of my custom code.

For other users who may have the same problem:
For me, this error message was requested:

Script Pimcore \ Composer :: installAssets handling the pimcore scripts event terminated with an exception:
An error occured when execute the “‘assets: install --symlink --relative’ \ ‘’ web ‘’ ‘’” command:

I found the cause in /var/logs/php.log. For me, an old configuration setting (from Pimcore 4, mail bounce) was the cause of a fatal error.
There was no problem with the updates before, only with the update to 6.2.1 did this error occur.