How to install PIM

Hello everyone
We are want to use product of PIM.

And how to install it via pimcore.zip?

Via composer is failed
COMPOSER_MEMORY_LIMIT=-1 composer create-project pimcore/skeleton ./my-project
cd ./my-project
./vendor/bin/pimcore-install

https://pimcore.com/docs/6.x/Development_Documentation/Getting_Started/Installation.html

It is only possible with composer!

Thank you for your reply,because I can’t upload attachments, I can only paste logs below
The following is the execution of COMPOSER_MEMORY_LIMIT = -1 composer create-project pimcore/skeleton /var/www/html/pimcore is the log. What is the problem?

Thank you for your reply,because I can’t upload attachments, I can only paste logs below
The following is the execution of COMPOSER_MEMORY_LIMIT = -1 composer create-project pimcore/skeleton /var/www/html/pimcore is the log. What is the problem?

Installing pimcore/skeleton (v2.5.3)

  • Installing pimcore/skeleton (v2.5.3): Loading from cache
    Created project in /root/pimcore
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Package operations: 140 installs, 0 updates, 0 removals
  • Installing ocramius/package-versions (1.4.2): Loading from cache
  • Installing wikimedia/composer-merge-plugin (v1.4.1): Loading from cache
  • Installing dasprid/enum (1.0.0): Loading from cache
  • Installing bacon/bacon-qr-code (2.0.0): Loading from cache
  • Installing symfony/polyfill-mbstring (v1.14.0): Loading from cache
  • Installing symfony/polyfill-ctype (v1.14.0): Loading from cache

  • Installing doctrine/migrations (v1.8.1): Loading from cache
  • Installing facebook/graph-sdk (5.7.0): Loading from cache
  • Installing google/apiclient-services (v0.127): Downloading (100%)
    Failed to execute (9) unzip -qq ‘/root/pimcore/vendor/google/apiclient-services/c3f74ec3761b89b14a53d2a246935b3b’ -d ‘/root/pimcore/vendor/composer/b17819ae’

[/root/pimcore/vendor/google/apiclient-services/c3f74ec3761b89b14a53d2a246935b3b]
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of /root/pimcore/vendor/google/apiclient-services/c3f74ec3761b89b14a53d2a246935b3b or
/root/pimcore/vendor/google/apiclient-services/c3f74ec3761b89b14a53d2a246935b3b.zip, and cannot find /root/pimcore/vendor/google/apiclient-services/c3f74ec3761b89b14a53d2a246935b3b.ZIP, period.

The archive may contain identical file names with different capitalization (which fails on case insensitive filesystems)
Unzip with unzip command failed, falling back to ZipArchive class

Invalid zip file, retrying...
  • Installing google/apiclient-services (v0.127): Downloading (connecting…)
    Downloading (85%)
    Downloading (100%)
  • Installing psr/http-message (1.0.1): Downloading (100%)
  • Installing ralouphie/getallheaders (3.0.3): Downloading (100%)
  • Installing guzzlehttp/psr7 (1.6.1): Downloading (100%)
  • Installing guzzlehttp/promises (v1.3.1): Downloading (100%)
  • Installing guzzlehttp/guzzle (6.5.2): Downloading (100%)
  • Installing firebase/php-jwt (v5.1.0): Downloading (100%)
  • Installing google/auth (v1.7.1): Downloading (100%)
  • Installing jdorn/sql-formatter (v1.2.17): Downloading (100%)
  • Installing khanamiryan/qrcode-detector-decoder (1.0.2): Downloading (100%)
  • Installing markbaker/complex (1.4.7): Downloading (100%)

  • Installing league/csv (9.5.0): Downloading (100%)

  • Installing hybridauth/hybridauth (v2.17.0): Downloading (100%)

  • Installing psr/http-factory (1.0.1): Downloading (100%)

  • Installing http-interop/http-factory-guzzle (1.0.0): Downloading (100%)

  • Installing google/apiclient (v2.4.0): Downloading (100%)

  • Installing geoip2/geoip2 (v2.10.0): Downloading (100%)

  • Installing endroid/qr-code (3.7.5): Downloading (100%)

  • Installing doctrine/doctrine-bundle (1.12.7): Downloading (100%)

  • Installing phar-io/manifest (1.0.3): Downloading (100%)

  • Installing phpunit/phpunit (7.5.20): Downloading (100%)

  • Installing codeception/phpunit-wrapper (7.8.0): Downloading (100%)

  • Installing codeception/stub (2.1.0): Downloading (100%)

  • Installing behat/gherkin (v4.6.1): Downloading (100%)

  • Installing codeception/codeception (2.4.5): Downloading (100%)

  • Installing codeception/codeception (2.4.5): Downloading (100%)
    bacon/bacon-qr-code suggests installing ext-imagick (to generate QR code images)
    symfony/contracts suggests installing psr/event-dispatcher (When using the EventDispatcher contracts)
    symfony/contracts suggests installing symfony/cache-implementation
    symfony/contracts suggests installing symfony/event-dispatcher-implementation
    symfony/contracts suggests installing symfony/http-client-implementation
    symfony/contracts suggests installing symfony/service-implementation
    symfony/contracts suggests installing symfony/translation-implementation
    doctrine/cache suggests installing alcaeus/mongo-php-adapter (Required to use legacy MongoDB driver)
    doctrine/doctrine-cache-bundle suggests installing symfony/security-acl (For using this bundle to cache ACLs)
    ocramius/proxy-manager suggests installing ocramius/generated-hydrator (To have very fast object to array to object conversion for ghost objects)
    ocramius/proxy-manager suggests installing zendframework/zend-json (To have the JsonRpc adapter (Remote Object feature))
    ocramius/proxy-manager suggests installing zendframework/zend-soap (To have the Soap adapter (Remote Object feature))
    ocramius/proxy-manager suggests installing zendframework/zend-xmlrpc (To have the XmlRpc adapter (Remote Object feature))
    guzzlehttp/psr7 suggests installing zendframework/zend-httphandlerrunner (Emit PSR-7 responses)
    maxmind-db/reader suggests installing ext-maxminddb (A C-based database decoder that provides significantly faster lookups)
    phpseclib/phpseclib suggests installing ext-libsodium (SSH2/SFTP can make use of some algorithms provided by the libsodium-php extension.)
    phpseclib/phpseclib suggests installing ext-mcrypt (Install the Mcrypt extension in order to speed up a few other cryptographic operations.)
    zendframework/zend-paginator suggests installing zendframework/zend-cache (Zend\Cache component to support cache features)
    zendframework/zend-paginator suggests installing zendframework/zend-db (Zend\Db component)
    zendframework/zend-paginator suggests installing zendframework/zend-filter (Zend\Filter component)
    zendframework/zend-paginator suggests installing zendframework/zend-json (Zend\Json component)
    zendframework/zend-paginator suggests installing zendframework/zend-view (Zend\View component)
    swiftmailer/swiftmailer suggests installing true/punycode (Needed to support internationalized email addresses, if ext-intl is not installed)
    monolog/monolog suggests installing aws/aws-sdk-php (Allow sending log messages to AWS services like DynamoDB)
    monolog/monolog suggests installing doctrine/couchdb (Allow sending log messages to a CouchDB server)
    monolog/monolog suggests installing ext-amqp (Allow sending log messages to an AMQP server (1.0+ required))
    monolog/monolog suggests installing ext-mongo (Allow sending log messages to a MongoDB server)
    monolog/monolog suggests installing graylog2/gelf-php (Allow sending log messages to a GrayLog2 server)
    monolog/monolog suggests installing mongodb/mongodb (Allow sending log messages to a MongoDB server via PHP Driver)
    monolog/monolog suggests installing php-amqplib/php-amqplib (Allow sending log messages to an AMQP server using php-amqplib)
    monolog/monolog suggests installing php-console/php-console (Allow sending log messages to Google Chrome)
    monolog/monolog suggests installing rollbar/rollbar (Allow sending log messages to Rollbar)
    monolog/monolog suggests installing ruflin/elastica (Allow sending log messages to an Elastic Search server)
    monolog/monolog suggests installing sentry/sentry (Allow sending log messages to a Sentry server)
    symfony-cmf/routing-bundle suggests installing doctrine/orm (To enable support for the ORM entities (^2.5))
    symfony-cmf/routing-bundle suggests installing doctrine/phpcr-bundle (To enable support for the PHPCR ODM documents)
    symfony-cmf/routing-bundle suggests installing doctrine/phpcr-odm (To enable support for the PHPCR ODM documents (^1.4))
    sensio/framework-extra-bundle suggests installing symfony/psr-http-message-bridge (To use the PSR-7 converters)
    sabre/vobject suggests installing hoa/bench (If you would like to run the benchmark scripts)
    paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
    ramsey/uuid suggests installing ext-libsodium (Provides the PECL libsodium extension for use with the SodiumRandomGenerator)
    ramsey/uuid suggests installing ext-uuid (Provides the PECL UUID extension for use with the PeclUuidTimeGenerator and PeclUuidRandomGenerator)
    ramsey/uuid suggests installing moontoast/math (Provides support for converting UUID to 128-bit integer (in string form).)
    ramsey/uuid suggests installing paragonie/random-lib (Provides RandomLib for use with the RandomLibAdapter)
    ramsey/uuid suggests installing ramsey/uuid-console (A console application for generating UUIDs with ramsey/uuid)
    ramsey/uuid suggests installing ramsey/uuid-doctrine (Allows the use of Ramsey\Uuid\Uuid as Doctrine field type.)
    piwik/device-detector suggests installing ext-yaml (Necessary for using the Pecl YAML parser)
    phpoffice/phpspreadsheet suggests installing dompdf/dompdf (Option for rendering PDF with PDF Writer)
    phpoffice/phpspreadsheet suggests installing jpgraph/jpgraph (Option for rendering charts, or including charts with PDF or HTML Writers)
    phpoffice/phpspreadsheet suggests installing mpdf/mpdf (Option for rendering PDF with PDF Writer)
    phpoffice/phpspreadsheet suggests installing tecnickcom/tcpdf (Option for rendering PDF with PDF Writer)
    linfo/linfo suggests installing ext-com (On Windows)
    google/apiclient suggests installing cache/filesystem-adapter (For caching certs and tokens (using Google_Client::setCache))
    doctrine/doctrine-bundle suggests installing doctrine/orm (The Doctrine ORM integration is optional in the bundle.)
    pimcore/pimcore suggests installing elasticsearch/elasticsearch (Required for Elastic Search service)
    pimcore/pimcore suggests installing ext-imagick ()
    pimcore/pimcore suggests installing ext-redis (
    )
    pimcore/pimcore suggests installing heidelpay/heidelpay-php (Required for Heidelpay payment)
    pimcore/pimcore suggests installing klarna/checkout (Required for Klarna payment)
    pimcore/pimcore suggests installing mpay24/mpay24-php (Required for MPay24 payment)
    pimcore/pimcore suggests installing paypal/paypal-checkout-sdk (Required for Paypal payment)
    facebook/webdriver suggests installing ext-SimpleXML (For Firefox profile creation)
    sebastian/global-state suggests installing ext-uopz ()
    phpunit/php-code-coverage suggests installing ext-xdebug (^2.6.0)
    phpunit/phpunit suggests installing ext-xdebug (
    )
    phpunit/phpunit suggests installing phpunit/php-invoker (^2.0)
    codeception/codeception suggests installing aws/aws-sdk-php (For using AWS Auth in REST module and Queue module)
    codeception/codeception suggests installing codeception/phpbuiltinserver (Start and stop PHP built-in web server for your tests)
    codeception/codeception suggests installing codeception/specify (BDD-style code blocks)
    codeception/codeception suggests installing codeception/verify (BDD-style assertions)
    codeception/codeception suggests installing flow/jsonpath (For using JSONPath in REST module)
    codeception/codeception suggests installing league/factory-muffin (For DataFactory module)
    codeception/codeception suggests installing league/factory-muffin-faker (For Faker support in DataFactory module)
    codeception/codeception suggests installing stecman/symfony-console-completion (For BASH autocompletion)
    codeception/codeception suggests installing symfony/phpunit-bridge (For phpunit-bridge support)
    Package zendframework/zend-eventmanager is abandoned, you should avoid using it. Use laminas/laminas-eventmanager instead.
    Package zendframework/zend-code is abandoned, you should avoid using it. Use laminas/laminas-code instead.
    Package zendframework/zend-stdlib is abandoned, you should avoid using it. Use laminas/laminas-stdlib instead.
    Package container-interop/container-interop is abandoned, you should avoid using it. Use psr/container instead.
    Package zendframework/zend-servicemanager is abandoned, you should avoid using it. Use laminas/laminas-servicemanager instead.
    Package zendframework/zend-paginator is abandoned, you should avoid using it. Use laminas/laminas-paginator instead.
    Package facebook/webdriver is abandoned, you should avoid using it. Use php-webdriver/webdriver instead.
    Generating optimized autoload files
    Deprecation Notice: Class Zxing\Common\CharacterSetEci\AbstractEnum\AbstractEnum located in ./vendor/khanamiryan/qrcode-detector-decoder/lib/Common/AbstractEnum.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\DependencyInjection\RouteAnnotationEventListenerTest located in ./vendor/presta/sitemap-bundle/Tests/DependencyInjection/PrestaSitemapExtensionTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\RouteAnnotationEventListenerTest located in ./vendor/presta/sitemap-bundle/Tests/EventListener/RouteAnnotationEventListenerTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\GeneratorTest located in ./vendor/presta/sitemap-bundle/Tests/Service/GeneratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\SitemapindexTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/SitemapindexTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleImageTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleImageTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleImageUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleImageUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleMobileUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleMobileUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleMultilangUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleMultilangUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleNewsUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleNewsUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleVideoUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleVideoUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\UrlConcreteTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/UrlConcreteTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\UrlsetTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/UrlsetTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\UtilsTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/UtilsTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20180724144005 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20180724144005.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20180830113528 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20180830113528.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20180830122128 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20180830122128.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20180904201947 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20180904201947.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
    Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20180906142115 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20180906142115.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201

standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20200212130011 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20200212130011.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20200218104052 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20200218104052.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class OpcacheGui\OpCacheService located in ./vendor/amnuts/opcache-gui/index.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Doctrine\Bundle\MigrationsBundle\Tests\DependencyInjection\DoctrineCommandTest located in ./vendor/doctrine/doctrine-migrations-bundle/Tests/Command/DoctrineCommandTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Package container-interop/container-interop is abandoned, you should avoid using it. Use psr/container instead.
Package facebook/webdriver is abandoned, you should avoid using it. Use php-webdriver/webdriver instead.
Package zendframework/zend-code is abandoned, you should avoid using it. Use laminas/laminas-code instead.
Package zendframework/zend-eventmanager is abandoned, you should avoid using it. Use laminas/laminas-eventmanager instead.
Package zendframework/zend-paginator is abandoned, you should avoid using it. Use laminas/laminas-paginator instead.
Package zendframework/zend-servicemanager is abandoned, you should avoid using it. Use laminas/laminas-servicemanager instead.
Package zendframework/zend-stdlib is abandoned, you should avoid using it. Use laminas/laminas-stdlib instead.
Generating optimized autoload files
Deprecation Notice: Class Zxing\Common\CharacterSetEci\AbstractEnum\AbstractEnum located in ./vendor/khanamiryan/qrcode-detector-decoder/lib/Common/AbstractEnum.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\DependencyInjection\RouteAnnotationEventListenerTest located in ./vendor/presta/sitemap-bundle/Tests/DependencyInjection/PrestaSitemapExtensionTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\RouteAnnotationEventListenerTest located in ./vendor/presta/sitemap-bundle/Tests/EventListener/RouteAnnotationEventListenerTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\GeneratorTest located in ./vendor/presta/sitemap-bundle/Tests/Service/GeneratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\SitemapindexTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/SitemapindexTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleImageTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleImageTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleImageUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleImageUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleMobileUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleMobileUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleMultilangUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleMultilangUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleNewsUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleNewsUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\GoogleVideoUrlDecoratorTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/GoogleVideoUrlDecoratorTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\Url\UrlConcreteTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/Url/UrlConcreteTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\UrlsetTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/UrlsetTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Presta\SitemapBundle\Test\Sitemap\UtilsTest located in ./vendor/presta/sitemap-bundle/Tests/Sitemap/UtilsTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20180724144005 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20180724144005.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20180830113528 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20180830113528.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20180830122128 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20180830122128.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201

Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20200211115044 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20200211115044.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20200212130011 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20200212130011.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Pimcore\Bundle\CoreBundle\Migrations\Version20200218104052 located in ./vendor/pimcore/pimcore/bundles/CoreBundle/Resources/migrations/Version20200218104052.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class OpcacheGui\OpCacheService located in ./vendor/amnuts/opcache-gui/index.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Doctrine\Bundle\MigrationsBundle\Tests\DependencyInjection\DoctrineCommandTest located in ./vendor/doctrine/doctrine-migrations-bundle/Tests/Command/DoctrineCommandTest.php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///usr/sbin/composer/src/Composer/Autoload/ClassMapGenerator.php:201
ocramius/package-versions: Generating version class…
ocramius/package-versions: …done generating version class

Pimcore\Composer::postInstall
Pimcore\Composer::clearCache

// Clearing the cache for the prod environment with debug
// false

[OK] Cache for the “prod” environment (debug=false) was successfully cleared.

Pimcore\Composer::installAssets

Trying to install assets as relative symbolic links.


  Bundle               Method / Error

:heavy_check_mark: PimcoreCoreBundle relative symlink
:heavy_check_mark: PimcoreAdminBundle relative symlink


[OK] All assets were successfully installed.

ocramius/package-versions: Generating version class…
ocramius/package-versions: …done generating version class

Pimcore\Composer::postInstall
Pimcore\Composer::clearCache

// Clearing the cache for the prod environment with debug
// false
[OK] Cache for the “prod” environment (debug=false) was successfully cleared.

Pimcore\Composer::installAssets

Trying to install assets as relative symbolic links.


  Bundle               Method / Error

:heavy_check_mark: PimcoreCoreBundle relative symlink
:heavy_check_mark: PimcoreAdminBundle relative symlink


[OK] All assets were successfully installed.

Pimcore\Composer::postCreateProject
[root@localhost html]#