I cannot install skeleton pimcore

Greetings everybody;

I have issues installing the pimcore skeleton on (Linux / windows) system.

I tried to install Pimcore following the Docs:

• Installed php 7.x with all its plugins.
• Installed MySQL, created DB with unique user with root privilege.
• Executed composer create-project pimcore/skeleton:dev-master 100% during installation.

• I ended up with partially full solution:
o ( no WebToPrint / PDFFactory / User config menu … etc.)
o a lot of bugs on symphony backend.

I tried to install Pimcore with docker image:
• no results and the container wouldn’t even start

I tried to install Pimcore within WampServer on windows:
• no results either.

My question here how can I install full Pimcore community version without any bugs or flows
Is there any way to do that ?

And why there no brut version without getting through package manager ?

Cordially.

Hi newart47,

If you use Docker it is simple:

My docker-compose-file:

version: '2.0'
services:
  redis:
    image: redis:alpine
    container_name: pimcore-redis

  db:
    image: mariadb:10.1
    container_name: pimcore-mariadb
    working_dir: /application
    command: [mysqld, --character-set-server=utf8mb4, --collation-server=utf8mb4_unicode_ci, --innodb-file-format=Barracuda, --innodb-large-prefix=1, --innodb-file-per-table=1]
    volumes:
      - ./db/:/var/lib/mysql
      - ./init/:/docker-entrypoint-initdb.d
    environment:
      - MYSQL_ROOT_PASSWORD=xxx
      - MYSQL_DATABASE=xxx
      - MYSQL_USER=xxx
      - MYSQL_PASSWORD=xxx

  adminer:
    image: adminer
    ports:
      - 2002:8080

  php:
    image: dpfaffenbauer/pimcore:PHP7.2-apache
    container_name: pimcore-php
    volumes:
      - ./src/:/var/www/html:cached
      - ./init/uploads.ini:/usr/local/etc/php/conf.d/uploads.ini
    ports:
     - "80:80"
     - "443:443"
    links:
     - db:db
     - redis:redis

  php-debug:
    image: dpfaffenbauer/pimcore:PHP7.2-apache-debug
    container_name: pimcore-debug-php
    volumes:
      - ./src/:/var/www/html:cached
      - .init//uploads.ini:/usr/local/etc/php/conf.d/uploads.ini
    ports:
     - "2006:80"
    links:
     - db:db
     - redis:redis
    environment:
      - PHP_IDE_CONFIG="serverName=localhost"

don’t forget to define database-setting in docker-compose-file (“xxx”).
Create folder “db”, “src” and “init” near your “docker-compose”-file.
Create “uploads.ini” (into “init”-folder) with content like this:

file_uploads = On
memory_limit = 64M
upload_max_filesize = 1G
post_max_size = 1G
max_execution_time = 30
memory_limit = 512M
short_open_tag=Off

Now you have a clean system to install pimcore.

Logging into docker-container:
docker exec -it pimcore-php /bin/bash

Change directory to:
cd /var/www

install project:
COMPOSER_MEMORY_LIMIT=-1 composer create-project pimcore/skeleton html

Change Directory to:
cd /var/www/html

install pimcore:
./vendor/bin/pimcore-install

Change Owner to www-data:
chown -R www-data:www-data /var/www/html

start pimcore-backend with your favorit browser:
http://localhost/admin

Andreas

That’s the same docker file i used to deploy Pimcore
but no success !
Thank you for your response.

that is my docker file and my images, so they do work :wink: you just did something wrong.

its hard to tell what you are doing wrong, can you describe what you already did and why you failed?

Dear Mr. dpfaffenbauer
Thank you for taking the time to response.:wink:

I know it’s your docker file and images
cause i took it from your Github Account :blush:

Here the issues i encountered during the installation:

The pull went smooth:
but at the end:


php debug problem
couldn’t log into docker-container

containers status

cordially

There is some kind of error starting the container. But I can’t read it from the screenshot. Can you paste it?

it seems your docker compose is configured to use port 80, and that is already in use

ok so i passed most of all the installation with success;
this is what encountered when i tried to install it

Problem solved … installed successfully.
Thank you Mr mediafant & dpfaffenbauer.