Inconsistent config values

#1

I am trying to get the symphiony debug toolbar to appear. In the docs it points us to the Symphony docs… after try a few things I added this to my config_local.yml file

pimcore:
    web_profiler:
        toolbar:              true
        intercept_redirects:  false
        excluded_ajax_paths:  ^/(app(_[\\w]+)?\\.php/)?_wdt

        # DEPRECATED, it can be removed safely from your configuration
        position:             bottom

        # DEPRECATED, it can be removed safely from your configuration
        verbose:              true

this fails with an exception saying “Invalid type for path “pimcore.web_profiler.toolbar”. Expected array, but got boolean”

This code is straight from the docs, so what gives?

1 Like
#2

Same here. Can’t find any documentation on how this configuration should be structured. I did a dump of the config and this is what it looks like:

pimcore:
    web_profiler:
        toolbar:
            excluded_routes:
                -
                    path: ^/admin/asset/image-editor
                    route: false
                    host: false
                    methods: {  }

I’m just trying to disable the profiler without turning off debug. The profiler files are eating up all my hard drive space.

#3

to turn it off use this:

framework:
    profiler:
        enabled: false