Installation of specific pimcore version

Hi!
Just wanted to install specific version 6.2.3 of Pimcore using composer. What is the correct way to do this? Tried

COMPOSER_MEMORY_LIMIT=-1 composer create-project pimcore/skeleton:6.2.3 awmpimcore6

Ends in

[InvalidArgumentException] Could not find package pimcore/skeleton with version 6.2.3.

Any idea how to handle this?

Use the latest skeleton and then do:

composer req pimcore/pimcore:6.2.3

hi and thank you.
problem is that I don’t have PHP 7.4, what is required latest skeleton. when trying to install, i get

$ COMPOSER_MEMORY_LIMIT=-1 composer create-project pimcore/skeleton awmpimcore6

Installing pimcore/skeleton (v2.3.4)

  • Installing pimcore/skeleton (v2.3.4): Loading from cache
    Created project in awmpimcore6
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for ocramius/proxy-manager 2.5.0 -> satisfiable by ocramius/proxy-manager[2.5.0].
- ocramius/proxy-manager 2.5.0 requires php ^7.4.0 -> your PHP version (7.3.11) does not satisfy that requirement.
Problem 2
- ocramius/proxy-manager 2.5.0 requires php ^7.4.0 -> your PHP version (7.3.11) does not satisfy that requirement.
- doctrine/migrations v1.8.1 requires ocramius/proxy-manager ^1.0|^2.0 -> satisfiable by ocramius/proxy-manager[2.5.0].
- Installation request for doctrine/migrations v1.8.1 -> satisfiable by doctrine/migrations[v1.8.1].

Remove composer.lock and do it again.