Installation stops - "Intl is required"


the composer installation worked so far, but when I try to run the vendor/bin/pimcore-install-script, it stops with the message “Intl is required.”

The problem is, that I don´t know how to enable php-intl in a way, that pimcore recognizes it.
It should be already included on a Mac (OSX High Sierra).
In this stackoverflow post, it is suggested to re-install php via brew:

But before messing up with my php configuration, I would like to know if there´s a simpler way?

In my MAMP configuration, for example, I can clearly see, that php-intl is enabled.
Could I tell pimcore to use the MAMP php configuration instead?
(Right now, the pimcore installation process looks into the /etc/php.ini instead of /Applications/MAMP/…)

Thank you very much for further information!
Best regards,


Not Pimcore looks into the wrong config, php does :wink:

use /Applications/MAMP/bin/php7.1.*/bin/php vendor/bin/install -> replace * with your php version


Thanks a lot!
That helped. The installation is now running.



I am facing ERROR: intl is required though i have tried by commenting the extension=php_intl.dll extension file in php.ini file. I can see php_intl.dll file in ext folder of php.

Please help me to resolve the issue as i am new to Pimcore.

Thank You:)
Amulya G


This post inspired me to search how to use MAMP PHP with Composer.

export PATH=/Applications/MAMP/bin/php/php7.x.x/bin/:$PATH

Now I have a new problem to solve

Your requirements could not be resolved to an installable set of packages.
Problem 1
- pimcore/pimcore v5.6.0 requires amnuts/opcache-gui ^2.4.0 -> satisfiable by amnuts/opcache-gui[v2.4.0].
- pimcore/pimcore v5.6.1 requires amnuts/opcache-gui ^2.4.0 -> satisfiable by amnuts/opcache-gui[v2.4.0].
- pimcore/pimcore v5.6.2 requires amnuts/opcache-gui ^2.4.0 -> satisfiable by amnuts/opcache-gui[v2.4.0].
- pimcore/pimcore v5.6.3 requires amnuts/opcache-gui ^2.4.0 -> satisfiable by amnuts/opcache-gui[v2.4.0].
- amnuts/opcache-gui v2.4.0 requires ext-zend-opcache * -> the requested PHP extension zend-opcache is missing from your system.
- Installation request for pimcore/pimcore ~5.6.0 -> satisfiable by pimcore/pimcore[v5.6.0, v5.6.1, v5.6.2, v5.6.3].

It’s a fresh machine (reinstalled OS 1 month ago), not a typical PHP developer, emphasizing: easy start, wider adoption.

The moment solving a single error yields two errors - amnuts/opcache-gui and zend-opcache I question if I want to continue… I solve these two and then another 7?

Then another thought - opcache-gui probably requires opcache (with not gui) but that’s probably zend-opcache.



composer install --ignore-platform-reqs

opcache should be disabled for dev anyway… otherwise you could end up into cached php code -> which sucks for development