Installation with composer -> killed!


#1

Hi there. try to install PC5.4. Can you say if i’m doing something wrong? Don’t have that much experience with composer. (see screenshot). Thanks!

pimcore-killed2


#2

Seems like your server kills processes that run longer than a certain period of time or need more memory than a certain amount of memory allowed.

Can you check with your Hoster?


#3

Makes sense to me. I wrote them as well. will give you feedback.
thanks so far.


#4

My solution: Since I develop locally, I create the composer.lock file locally und upload with deployment. On deployment I do "composer install && composer run-script post-update-cmd " instead of “composer update”


#5

post-update-cmd and post-install-cmd is almost the same. except for the Pimcore Core migrations. And I don’t run them with composer-updates, I run them with my deployment process.

Versioning and deploying with the composer.lock is the way to go, as it gives you exactly the same versions of every lib you have locally, as if you do it without a composer.lock you could get different versions based on your version constraints and thus result into errors that are not reproducible locally.


#6

I tryed also local installation with composer. also get the out of memory message. in PHP ini I set the limit to 3G as you can see in the picture. any ideas?


#7

Probably you have set limit in wrong php.ini file , run

php -r "phpinfo();" | grep php.ini

to identify the path of correct php.ini as you need to make changes in cli php.ini.

After making changes run
php -r "phpinfo();" | grep memory_limit

to check the limit .

BTW you can set memory_limit to -1 for no limit.

Regards


#8

run either like

php -d memory_limit=-1 composer

or

COMPOSER_MEMORY_LIMIT=-1 composer

https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors


#9

well i tried it local on 2 different enviroments. when i check memory limit with composer i get the “-1”
so far so good. but really not able to install it without errors. a part is downloaded, a part not. any other possibillity to deploy? or can anyone make a deployment kit? :-/