Launch Installer - No such file or directory


I am following the below link of documentation to install Pimcore.

In the 4th step of documentation, launch installer, as i run the command
cd ./my-project
its says No such file or directory
I also checked in vendor folder, there is no bin folder present.

How should I proceed from here?

Thanks in advance!


Please go through your logs and check that composer has run fine and downloaded all the required files.
It’s very strange that you are not having that directory. I have multiple instances of it and never faced such issue. Installer is always there in the vendor/bin directory.
Also try again with different installation package.



It happened to me too.
Composer did not completely and successfully finish the download.
I’ve relaunched the download a bunch of times and vendor/bin it’s appeared.



@fedriz I have uninstalled and tried again few times, but still couldn’t get bin folder inside vendor


@avneesh-webkul As far as I checked there is no problem with composer. When I ran composer install, it displayed nothing to update.


composer.json looks like this


"name": "pimcore/demo-ecommerce",

"description": "E-Commerce Demo Application for Pimcore 5",

"type": "pimcore-install-profile",

"license": "GPL-3.0-or-later",

"config": {

"sort-packages": true


"require": {

"php": ">=7.0",

"pimcore/advanced-object-search": "^1.5",

"pimcore/core-version": "~5.3.0",

"pimcore/customer-management-framework-bundle": "^1.8",

"pimcore/web2print-tools-bundle": "^2.3"




Problem solved. Issue was on composer, it was not installed properly.