Mysql 8 - trouble installing Pimcore - unable to set innodb_file_format, etc

innodb_file_format = Barracuda
innodb_large_prefix = 1
innodb_file_per_table = 1
innodb_default_row_format = dynamic

every time I put these in the cnf file, mysql fails to start. I’m using mysql 8 instead of 5.7. Pimcore technically runs without these settings, but I remember there being impacts. Also unable to set it through the terminal. Running SET GLOBAL innodb_large_prefix=1; for example returns “Unknown system variable ‘innodb_large_prefix’.” Anyone had similar issues?

After further research I found out that those four parameters have been deprecated in mysql 8, the version I currently have. So it is probably not a good idea to use it, for anyone else who had a similar problem. Just stick to good old mariadb or mysql 5.7

This is untested, but mysql 8 might have long enough keys by default. If you can install Pimcore and it works, it probably will continue to. Create a couple classes and see if the objet tables get created correctly. If that runs fine, then using MySQL 8 should be OK.
But again, untested opinion :wink:

they have been deprecated cause it’s the default setting now…