MySQL Parameter (Barracuda, etc.)


#1

Hi,

I was wondering if it is really necessary to change the mariadb file format to Barracuda and set innodb_large_prefix = 1. Because this changes makes it impossible to install Pimcore 5.x on a “regular shared” webhosting (allinkl in my case).

As I could install Pimcore 3.x without any problems on a shared webhosting, starting with 4.x there has been a dependency to memcached and now 5.x is complaining about missing my.cnf parameters (as mentioned above) when trying to run the install script.

So are those my.cnf changes are really required to run pimcore?

Thx & BR,
Alex


#2

Hate it too, but yes, it is necessary


#3

Do you know what would not be functional if these settings are not set?


#4

@leuchtdiode: read more about this here: https://github.com/pimcore/pimcore/issues/1754


#5

Alright, thanks for the explanation.


#6

Do I understand it right? By installing a fresh Pimcore instance, the installer sets the keys/filenames to ascii and I do not have to set the innodb_-settings?

Is there a way to overwrite this for the update process? My customers won’t be very happy to leave there hoster or take a root server just for setting those vars… :wink:


#7

Nope, these settings are a requirement now. Even for updates. If you have a hoster like hetzner, they support this out-of-the-box anyway.


#8

I get the point of @daniel.schmieder. It’s not optimal that pimcore 5.1.x is not running on my hoster allinkl any longer. It’s impossible for me now to update some instances I’m running.


#9

I absolutely understand this change. But the possibility to switch off the utf8 support and keep the ascii names as before would be great… Maybe there’s an inofficial way to achieve this. Have to check this out or does anybody already had a look for this?