Pimcore formbuilder

Hi,

I am trying to install pimcore formbuilder 3.x on PIM with version 6.4.2. I am getting the following error.

Timestamp: Fri Feb 07 2020 15:30:02 GMT+0530 (India Standard Time)
Status: 500 | Internal Server Error
URL: /admin/formbuilder/settings/get-tree?_dc=1581069602488
Method: GET
Message:

Fatal error: Declaration of FormBuilderBundle\Storage\Form\Listing::setData($data) must be compatible with Pimcore\Model\Listing\AbstractListing::setData(?array $data): Pimcore\Model\Listing\AbstractListing in /var/www/html/pimcore/vendor/dachcom-digital/formbuilder/src/FormBuilderBundle/Storage/Form/Listing.php on line 8
{“success”:false,“message”:“Compile Error: Declaration of FormBuilderBundle\Storage\Form\Listing::setData($data) must be compatible with Pimcore\Model\Listing\AbstractListing::setData(?array $data): Pimcore\Model\Listing\AbstractListing”,“trace”:[],“traceString”:“in /var/www/html/pimcore/vendor/dachcom-digital/formbuilder/src/FormBuilderBundle/Storage/Form/Listing.php:8\n#0 {main}”}

I know formbuilder is supporting 5.x version currently. Want to understand if there is a simpler fix to solve this. Let me know.

Regards
Shashi

I’ve just tried to install Formbuilder 3.2 on Pimcore 6.4.2 and got no errors.

You need to use FB 3.2 to run on Pimcore >= 6.4

Thanks. Yes this works with FB 3.2.

1 Like