Pimcore generate bundle command is not working. Command “pimcore:bundle:generate” is not defined

I am trying to execute this command to generate a Pimcore bundle but neither it is working nor it is showing in the command list.
Is there any settings to enable this command in Pimcore 5.4?
I have used this command in other previous Pimcore 5 versions and it was working fine without doing any settings.

$ bin/console -V
Pimcore v5.4.4 (kernel: app, env: prod, debug: false)
$ bin/console pimcore:bundle:generate
                                                     
  Command "pimcore:bundle:generate" is not defined.  
                                                     
  Did you mean one of these?                         
      pimcore:bundle:disable                         
      pimcore:bundle:enable                          
      pimcore:bundle:install                         
      pimcore:bundle:list                            
      pimcore:bundle:uninstall                       
      pimcore:bundle:update                          
      pimcore:documents:generate-page-previews       
      pimcore:migrations:generate                    

Thanks.

Hi,
should be there as always - it is called pimcore:generate:bundle

BR
Christian

I tried this command also. Here is the output:

$ bin/console pimcore:generate:bundle

                                                                      
  There are no commands defined in the "pimcore:generate" namespace.  
                                                                      
  Did you mean one of these?                                          
      doctrine:generate                                               
      pimcore                                                         
      pimcore:bundle                                                  
      pimcore:cache                                                   
      pimcore:classificationstore                                     
      pimcore:definition                                              
      pimcore:definition:import                                       
      pimcore:deployment                                              
      pimcore:documents                                               
      pimcore:email                                                   
      pimcore:image                                                   
      pimcore:migrations                                              
      pimcore:targeting                                               
      pimcore:thumbnails                                              
      pimcore:user                                                    
      pimcore:web2print

You probably run in prod mode. try:

bin/console pimcore:generate:bundle --env=dev

2 Likes

yes. I am in prod mode. I tried with --env=dev and it worked.
thanks.