Pimcore/pimcore v5.5.3 requires ext-zip


#1

when installing dependencies with composer.phar install I stumble on this

Your requirements could not be resolved to an installable set of packages.

Problem 1
- pimcore/pimcore v5.5.3 requires ext-zip * -> the requested PHP extension zip is missing from your system.
- pimcore/pimcore v5.5.2 requires ext-zip * -> the requested PHP extension zip is missing from your system.
- pimcore/pimcore v5.5.1 requires ext-zip * -> the requested PHP extension zip is missing from your system.
- pimcore/pimcore v5.5.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
- Installation request for pimcore/pimcore ~5.5.0 -> satisfiable by pimcore/pimcore[v5.5.0, v5.5.1, v5.5.2, v5.5.3].

To enable extensions, verify that they are enabled in your .ini files:
- /usr/local/php5/lib/php.ini
- /usr/local/php5/php.d/10-extension_dir.ini
- /usr/local/php5/php.d/20-extension-opcache.ini
- /usr/local/php5/php.d/40-curl.ini
- /usr/local/php5/php.d/40-openssl.ini
- /usr/local/php5/php.d/50-extension-apcu.ini
- /usr/local/php5/php.d/50-extension-curl.ini
- /usr/local/php5/php.d/50-extension-gmp.ini
- /usr/local/php5/php.d/50-extension-igbinary.ini
- /usr/local/php5/php.d/50-extension-imap.ini
- /usr/local/php5/php.d/50-extension-intl.ini
- /usr/local/php5/php.d/50-extension-mcrypt.ini
- /usr/local/php5/php.d/50-extension-mongodb.ini
- /usr/local/php5/php.d/50-extension-mssql.ini
- /usr/local/php5/php.d/50-extension-pdo_pgsql.ini
- /usr/local/php5/php.d/50-extension-pgsql.ini
- /usr/local/php5/php.d/50-extension-propro.ini
- /usr/local/php5/php.d/50-extension-raphf.ini
- /usr/local/php5/php.d/50-extension-readline.ini
- /usr/local/php5/php.d/50-extension-redis.ini
- /usr/local/php5/php.d/50-extension-xsl.ini
- /usr/local/php5/php.d/99-liip-developer.ini
You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.


#2

Hi. Have you the possibility to install the missing package (in your case php[YOUR_VERSION]-zip) on your system? Regards


#3

I was using php5 and after installing php 7.2 it all worked out. Thank you for your reply.