Problems with presta/sitemap-bundle

Hi,

I was upgrading my pimcore 5.6 to 6.6. After some smaller issues, that i was able to resolve, I encountered a strange behaviour regarding the Presta Sitemap Bundle.

I had a requirement on that bundle:
*** my composer.json ***

“pimcore/pimcore”: “6.6.",
“presta/sitemap-bundle”: "1.5.
”,

*** pimcore 6.6 composer.json ***

“presta/sitemap-bundle”: “^1.5”,

So everything should work right?

Just a small issue:

Removing my requirement on the presta/sitemap-bundle fixed the problems. However I would suggest to require a higher version of the bundle to ensure compatibility.
Or are there any other suggestions why I encountered this problem?

Best regards