REST API, Pimcore 7

I’m reading here that from Pimcore 7 and onwards the REST API will no longer be an option. Will there be any legacy bridge or compatibility mode for solutions relying on this?

Hi @ipmmichael

I don’t think so. Pimcore suggests to use the DataHub for API interfaces. ATM, only GraphQL is supported though…
Solutions/bundles relying on the “old” REST API will have to refactor.

Please see https://github.com/pimcore/pimcore/pull/5517

2 Likes