Scheduled publish creates new version with old data

Hi, it’s me again.
This time with a question not about the API but this time about the schedule and versions.

For testing I created an object class called “Product”. It’s a very simple one with only to fields. “SKU” and “Name”. Both are of type Input. Then i created a test object and called it “test product” and sku “test”.

Save and publish. No problem.

Then i changed to name to be “test product NEW”. Clicked “only save new version”.
I get a new version with the correct data. Name = “test product NEW”.

Then i create a Schedule to publish it. Click “Save only scheduled tasks”.

When the cron job runs and the Schedule is due. Something unexpected is happening.
I get a new version with my old data in it. Name = “test product”. (Not “test product NEW” as I expected)

I then tried the whole thing again. This time i picked a specific version for my schedule to publish.
Same thing. New version old data.

What the ?

Seems to not really work for me either. Maybe file a bug report?

Hi msphn.

I’m starting to think you are the only person on this forum :slight_smile:

I will report a bug. Thanks again :slight_smile:

No no theres also Dominik :innocent:

Issue created:

Hi, please make sure you are using correct option to publish a version “Publish Version” not “Publish” https://pimcore.com/docs/6.x/Development_Documentation/Tools_and_Features/Scheduling.html#page_General

I tried both Publish version and Publish. Both creates a new version with old data.

The “plain” publish would publish the newest version right?

So, these two options are for different purpose:

  1. publish version should be used to publish a version (to publish any specific version even when object is already published).
  2. publish should be used for changing the publish status (unpublished to published).

I tried publish version by selecting latest version and it creates a new version with latest data.