Shell installation - no option to enter database host


#1

Hey there,

i can´t enter the host for my database while the installation process?!
It jumps from:

“MySQL database:”

to:

“This will install Pimcore with the given settings. Do you want to continue? (yes/no) [yes]:”

If i type “yes”, i get clearly an error, this error:

Couldn’t establish connection to MySQL: An exception occurred in driver: SQLSTATE[HY000] [2002] No such file or directory

How should i enter the database-host, have I overlooked something? In the last installations the point for the host was present at the terminal…!?

thx


#2

vendor/bin/pimcore-install --mysql-host-socket=dbserver


#4

thanks for your help,
but i get the same error, and no option to enter the host…

This will install Pimcore with the given settings. Do you want to continue? (yes/no) [yes]:

yes

Running installation. You can find a detailed install log in var/installer/logs/prod.log

Checking prerequisites…

2/10 [=====>----------------------] 20%

[ERROR] The following errors were encountered during installation

  • Couldn’t establish connection to MySQL: An exception occurred in driver: SQLSTATE[HY000] [2002] No such file or directory

#5

Hi,
This error is normally caused by php which is trying to load a missing mysql.sock file (like /tmp/mysql.sock).
To solve this problem you first have to look which file are you trying to load (look at your php.ini) and then create it.

There are different possible solutions and it depends on your server configuration:
Please have a look at these links:



#6

nice thank you, i´ll check this out!


#7

Hey,

the solution from dpfaffenbauer was right.

vendor/bin/pimcore-install --mysql-host-socket=hostname

thx