[SOLVED] Fulltext Indexes is required during the installation


#1

hello all,
i get an error during the installation of pimcore demo-basic example
when i run the command
./vendor/bin/pimcore-install
–admin-username admin
–admin-password admin
–mysql-username root
–mysql-password 123456
–mysql-database project_database
–no-interaction

it is running till 20% then i get :

  • Fulltext Indexes is required.

indexing normally on table creation.
any suggestions?


#2

See what the check does and try it directly on your MySQL console:

CREATE TABLE __pimcore_req_check (
                  id int(11) NOT NULL AUTO_INCREMENT,
                  field varchar(190) DEFAULT NULL,
                  PRIMARY KEY (id)
                ) DEFAULT CHARSET=utf8mb4;
ALTER TABLE __pimcore_req_check ADD FULLTEXT INDEX `fulltextFieldIndex` (`field`)

This should lead you to the problem


#3

i added only : ENGINE=MyISAM DEFAULT CHARSET=utf8mb4;
Then it works
is it on install.sql?
or where should i edit ?


#4

i edit the mysql script by adding ENGINE=MyISAM DEFAULT CHARSET=utf8mb4; then all works fine


#5

HI, i have the same problem !!

it is running till 20% then i get :

Fulltext Indexes is required.

Where do i have to insert string: ENGINE=MyISAM DEFAULT CHARSET=utf8mb4; ??

I have insert string in file install.sql, but haven’t resolve problem.

I have modified file install.sql and insert manually strind in all CREATE TABLE, but don’t work, always same problem at 20%.

Let me know is very important for me.

Thanks in advance.

Best Regards
Antonello


#6

try to open the mysql by using workbench or any other management tool and execute this command
ENGINE=MyISAM DEFAULT CHARSET=utf8mb4;


#7

Hi @brusch,

I encountered the same ‘Fulltext Indexes is required’ error during installation, so I ran your CREATE TABLE and ALTER TABLE queries manually from my SQL client and they work without a problem (I confirmed creation of the table and the index). Still, the PimCore installer, configured to use that exact same database, fails with the message “Fulltext Indexes is required.”.

Do you have any idea what else I may try to pin down the problem? Thanks a lot!

UPDATE: I chose to temporarily echo the Exception message in Requirements.php at line 186, the Exception message reads:
SQLSTATE[HY000]: General error: 1214 The used table type doesn’t support FULLTEXT indexes

So it seems my client is creating a MyISAM table whereas the Installer creates an InnoDB table for which my server currently doesn’t support FULLTEXT indexes. I guess that answers my question.