[Solved] Pimcore with php7.3

I have pimcore installed on a Server with debian/ buster and php 7.3
hwo would you configure apache ? The config on the pmcore homepage doesn’t work.
what should I do ?

May you tell us a bit more about your specific problem? Does the Site not load, do you get any errors?

Did you make sure that you have installed Pimcore inside the /www folder? Otherwise Apache can’t access the files, you also have to set the correct document root inside apache config. Furthermore you should check if all files are owned by www-data (this is a linux user). This isn’t the case if u have installed pimcore with sudo or as root. You can check by typing: “ls -l” into commandline while u are inside the pimcore root. You can set the owner by going one step before pimcore root and type “sudo chown -R www-Data:www-Data /pimcoreRootFolder”…

Hi Lukas,
pimcore is installed insided /var/www/pimcore folder and www-data has access to it and 755 rights on all folders.

This is my apache conf

DocumentRoot /var/www/pimcore/web
SetEnvIfNoCase Request_URI "\.(php)$" no-gzip dont-vary

AddHandler php7.3 .php
Action php7.3 /php7.3
Alias /php7.3 /usr/lib/cgi-bin/php7.3


<Directory /usr/lib/cgi-bin>
    Options ExecCGI FollowSymLinks
    SetHandler fastcgi-script
    Require all granted
</Directory>
<Location /var/www/pimcore/web/>
Options FollowSymLinks
Require all granted
AllowOverride all
</Location>

The problem is , the paths don’t work.
this is what I got after installing the demo

none of the links work
I had the same problem when I tried it behind a reverse proxy

The problem is solved. The problem was, in the apache conf , you need to put in directory instead of Location with the directoy where pimcore islocated or apache ignores the .htacess file